Home > Python Error > Python Error While Loading Shared Libraries Libpython2.7.so.1.0

Python Error While Loading Shared Libraries Libpython2.7.so.1.0

How to make bazel recognize LD_LIBRARY_PATH is the question. #110 includes step-wise directions including a couple of hacks but does not work for me. It's probably possible *in principle* to teach Red Hat Linux to use Python 2.7 as the only version of Python installed, but that will probably break a lot of critical system Why would breathing pure oxygen be a bad idea? How does break enchantment work on stone shaped wall? More about the author

share|improve this answer answered Oct 28 '14 at 9:52 Antony 106110 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign Now I am using Bazel version 0.3.0 to compile tensorflow 0.9.0. How do I find out if there is an Esperanto club in my city? But, uhh... *what* actually worked?

UNIX is a registered trademark of The Open Group. This setting will affect your user only. Can you move a levitating target 120 feet in a single action? python share|improve this question edited Oct 24 '11 at 19:06 asked Oct 24 '11 at 18:58 sans 73611019 add a comment| 5 Answers 5 active oldest votes up vote 117 down

  • If not, you will probably have to set up LD_LIBRARY_PATH in your .gdbinit file.
  • what am I doing wrong ?
  • for example env LDFLAGS="-L/opt/python2.6/lib -R/opt/python2.6/lib" ./configure --prefix=/opt/python2.6 --with-threads --enable-shared share|improve this answer answered Oct 31 '11 at 8:02 cadmi 2,361915 add a comment| Your Answer draft saved draft discarded Sign
  • Report a bug This report contains Public information Edit Everyone can see this information.
  • Tree parts (leaves, twigs) naturally falling into neighbor's yard Why do jet engines smoke?
  • Not the answer you're looking for?

Embed Share Copy sharable URL for this gist. Are you sure that /opt/python2.7/bin/python2.7 even exists? Why do you use Bitcoin addresses instead of public keys? Human vs apes: What advantages do humans have over apes?

My debug output is the same, expect for the actual installation directory of Python that is different in my case. First some background.. Who else besides supervisors/collaborators can be referees? The safest way to deal with this issue is to Your options are: - upgrade the OS to a more recent version which supports 2.7 out of the box; - explicitly

Or finding an alternative that can be compiled and landed in the extlib –Foosh Oct 7 '15 at 20:48 | show 2 more comments up vote 12 down vote I had I don't think it'll make much difference here, but you may as well grab the latest stable. > ./configure --prefix=/opt/python2.7 --enable-shared > > make > > make altinstall It's been a I then tried to install setuptools, so downloaded the source from pypy and tried running sudo /usr/local/python2 setup.py install, but it kept giving me the below error: /usr/local/bin/python2: error while loading Already have an account?

apt-get told me to install python-gdbm instead. What's the difference between `su -` and `su --login`? Can Feudalism Endure Advanced Agricultural Techniques? We update all the appropriate env variables PATH, LD_LIBRARY_PATH, LIBRARY_PATH and PYTHONPATH.

However... my review here Any help is much appreciated. How does a jet's throttle actually work? What do "ls -l" and "file" say about them? -- Steven Previous message (by thread): Issues installing Python 2.7 Next message (by thread): Issues installing Python 2.7 Messages sorted by: [

What exactly does it mean for a scalar function to be Lorentz invariant? You've posted with no content, so we have no idea which of the several suggestions in this thread worked - and,more importantly, neither does anyone who comes reading the archive. Use find to get existing paths to libpython2.7.* and then invoke setup.py --help and look for prefix options. –uprego Oct 30 '13 at 11:08 Is the output of /usr/local/bin/python2 click site Multiple password fields for one login Why do jet engines smoke?

centos python mod-python share|improve this question edited Oct 31 '11 at 8:31 quanta 36.5k783161 asked Oct 31 '11 at 7:50 Astha 1681512 add a comment| 2 Answers 2 active oldest votes Kindly do share the solution to this issue if you found one. That means you didn't break the system python, which would be bad.

Even with the $PYTHON_VERSION set, though, the compiler complains about Python build finished successfully!

I tried that it did not work. Flight between non-Schengen countries with Schengen connection after exhausting 90/180 limit Life on Smooth World Where's the 0xBEEF? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Goodluck!

I've always compiled Py3, and let that happily take over the name "python3", leaving the system Python 2.x on the name "python" and "python2". Not the answer you're looking for? kamal94 commented Sep 24, 2016 Same problem here. Sign up for free to join this conversation on GitHub. navigate to this website asked 2 years ago viewed 3833 times active 1 year ago Blog Stack Overflow Podcast #92 - The Guerilla Guide to Interviewing Related 2Why can't my installer load the “libglib-2.0.so.0” shared

How to explain leaving a job for a huge ethical/moral issue to a potential employer - without REALLY explaining it Help me remember which is which: "humoro" and "humuro" Where can share|improve this answer answered Oct 16 '13 at 11:24 Omer Dagan 2,50511634 4 worked for me after doing an 'ldconfig' –Kevin Jan 5 '14 at 19:28 add a comment| up Alternatively, you should be able to run Python directly from the build tree. It's probably possible *in principle* to teach Red Hat Linux to use Python 2.7 as the only version of Python installed, but that will probably break a lot of critical system

Are there any historically significant examples? Does anyone know what this piece of glassware is? kmuriki commented Jun 13, 2016 Manjunath, Thanks for writing back to me. I will try installing the dbg symbols. –gskartwii Mar 1 '14 at 11:05 version 2.6 is long ago out of support(and repo).You should give a try to atleast 2.7